Accesstuner General Features


 

This software has been developed to provide tuners with the essential tools needed to properly calibrate a vehicle.  The "Accesstuner General Features" guide serves as a reference guide to general software functions.

How To Open the Accesstuner Professional Software

After installing Accesstuner Professional (ATP), insert the HASP key (purple USB device) to allow the computer to install the necessary device drivers. Accesstuner will not open without your HASP key plugged into the computer. Once the drivers are installed, double-click Accesstuner Pro desktop shortcut and select an ECU type.
Upon opening Accesstuner, you are asked to choose an ECU type. Accesstuner will populate the tables with information from the last map modified. If it is the first time Accesstuner is opened, or the first time the ECU type is selected, a message will indicate that the ECU type's stock map will be loaded.

Connecting to an ECU

There are two Accessport hardware configurations for the MAZDASPEED3/6/MPS in the field currently – a version 2 (v2) and a revised version 2 (v2b). Each version will have a slightly different method for connecting your computer to a vehicle's ECU.

  • V2 – Utilizes a silver and red OBD-II connector (“dongle”) and USB to USB Mini Type-B cable. Connect dongle to OBD-II port, mini USB to dongle, regular USB to computer.
  • V2B – Utilizes “pass-through” communications method. Connect computer to Accessport via supplied USB to USB Mini Type-B cable, then Accessport to OBD-II via supplied OBD-II to 9-pin, black cable. All communications will pass from the computer to the vehicle through the Accessport.
  • V3 - Utilizes “pass-through” communications method. Connect computer to Accessport via supplied USB to USB Micro cable, then Accessport to OBD-II via supplied OBD-II cable. All communications will pass from the computer to the vehicle through the Accessport. 

Compatibility

Accesstuner is compatible with two map types – Professional and Race – which both use the file extension .ptm.

  • Pro – created with Accesstuner Professional and locked to a vendor name and/or Accessport serial number. Can not be opened by versions of Accesstuner Professional that do not match the vendor name or by Accesstuner Race, unless map is “unlocked”.  Cannot be used by Accessports that do not match the serial number designated when saving the map.
  • Race – Anyone with Accesstuner Professional/Race can open map to view/modify table data. If saved within Accesstuner Professional, an option to lock the map by Accessport serial number is available.\

Accesstuner Menu Options

Under the File, Edit, View, ECU and Help pull-down menus, you will find tools to modify a calibration and set up the Accesstuner software. Below are more in-depth descriptions of these menus.

File Menu

File - Load Map [Ctrl + Alt + O]

To load a map into Accesstuner, go to File ? Load Map ? Pro (or Race) and browse for the desired map. Select the map and click Open to populate the calibration tables.

File - Save Map [Ctrl + Alt + S]

To save a map from Accesstuner, go to File -> Save Map -> Pro (or Race).

A prompt will appear to input information about the map.

  • Short Description - what is seen as the name of the file; therefore, it is recommended that this description be concise.
  • Long Description - allows for greater detail, such as boost levels, noteworthy changes to the calibration, or what mechanical components the map was created for.
  • Revision - used to keep track of how many revisions the map has gone through.
  • Serial Number (only accessible in ATP) - allows you to lock a map to a particular Accessport serial number. Check this box, then enter the last 5 digits of the customer's serial number to lock the map.

Alternatively these entries can be edited by opening a map, then going to Edit -> Base Map Properties.
All of this information can be seen in the Accessport Manager software.
After inputting this data, you will be prompted to choose where the file will be saved.

File - Revert to Working Map [Ctrl + I]

After altering a map, you are able to load the original saved map by choosing this option. This will revert all changes made since the map was last saved.

File - Revert Changes in Active Table

This tool works like the Revert to Working Map, but reverts only the active table in the editor back to the information from the saved map file.

File - Revert to Stock Map [Ctrl + K]

Using this tool allows you to load stock information to all tables.
*Please be aware that using this option without saving your calibration will cause all changes made since the last save to be lost.

File - Manage Maps [Ctrl + Alt + M]

Opens Accessport Manager, allowing you to load maps to any Accessport plugged into the computer. Also allows downloading/viewing Data Log files and other information from the Accessport.

File - Exit [Alt + F4]

Exits the Accesstuner Software.

Edit Menu

Edit - Undo [Ctrl + Z]

Used to undo last change made.

Edit - Copy Selected Cell Values [Ctrl + C]

Used to copy selected information.

Edit - Paste Copied Cell Values [Ctrl + V]

Used to paste data copied/stored on your PC clipboard.

Edit - Advanced Parameters [Ctrl + A]


Advanced Parameters is presented in two categories - DTCs (Base) and Toggles (Base). Checked or un-checked DTCs will cause the corresponding code to be active/inactive in a vehicle's ECU. The list of DTCs available is comprised of those commonly encountered with aftermarket modification.
A checked DTC will remain active in the ECU.
Unchecking a DTC will cause the corresponding CEL (Check Engine Light) code to stay in a “Not Ready” state, preventing the CEL from activating in the vehicle.

Edit - Configure Options [Ctrl + F]

Configure Options is broken into 5 categories to set up the Accesstuner software. These options only impact the tuning software and its presentation.

  • Gauge List - This tab contains all possible monitors that are viewable when using the Dashboard. Simply check desired monitors that you wish to view while using the Dashboard. Accesstuner will remember the chosen parameters per ECU type so you will not have to pick these the next time you open the software for the same ECU. The Dashboard is a window that can be used while recording data logs to actively monitor your chosen parameters. Viewing too many parameters can slow down the software's sample rate. It is recommended to view 12-16 parameters max.
  • Log List - This tab contains all possible monitors that will be logged when using the Accesstuner's data logging feature. Check the desired monitors that you wish to capture. Accesstuner will remember the chosen parameters per ECU type so you will not have to pick these the next time you open the software for the same ECU. Logging too many parameters can slow down the software's sample rate. It is recommended to log 12-16 parameters max.
  • Display - This tab contains preferences for how data is displayed.
    • Data Display Options
      • Show Standard Units is a check-box to toggle all table data and data logging data between standard and metric units.
      • Use Weighted Interpolation is a check-box to display the bounding box used for Live Tracing. Checking this will cause Live Trace to appear smoother. Un-checking this makes the Live Trace box fit only in active cells.
    • Map List Options
      • Expand All is used to expand all table categories upon opening Accesstuner software.
    • Graph Display Options - Allows you to customize the way graphs within tables are displayed.
  • Logging - Logging tab is used to setup the location where data logs are stored and how they are saved. Default location is the Accesstuner installation folder
    • (Example - C:\ProgramFiles\Accessport\Accesstuner Pro – MAZDASPEED).
  • Communications
    • This tab is used to indicate if you are using the COBB USB cable or serial cable. Do not modify the other settings in this menu unless instructed to do so.
  • Aftermarket Wide-band Oxygen Sensor Integration
    • The remaining tabs configure and enable wide-band O2 sensors. External wide-band O2 sensors can be integrated into the software for data logging and Dashboard viewing. Once enabled, additional monitors will be available in Gauge List and Log List.

Edit - Base Map Properties

Base Map Properties is used to edit details about the map. This can be modified at anytime during the tuning process or can be edited when saving a map.

Compare Menu

Newer versions of Accesstuner Pro for select manufacturers include map compare. Map compare allows calibrations to be compared to existing or stock files.

  • More details on map compare can be found here.

View Menu

View - Dashboard [Ctrl + B]

Checking this option opens Dashboard. Dashboard will only display parameters set in the Gauge List. Once Dashboard is open, it can be moved and re-sized.

View - Table List [Ctrl + P]

Checking this option shows the list of all available tables to modify for the selected ECU.

View - Table Graph [Ctrl + H]

Checking this option adds a window to show your selected table values in the form of a graph.

View - Status Bar [Ctrl + U]

Checking this option opens a bar along the bottom of the software to display information about the state of the software instance.

View - Data Log Viewer [Ctrl + Shift + D]

Checking this option opens a built-in data log viewer. Information is displayed in columns and rows.


View - Live Tracing [Ctrl + T]

Checking this option enables a bounding box to appear around data in the active table, indicating what part of the table is being utilized by the ECU. This feature is not enabled one every table.

ECU Menu

ECU - Data Logging [Ctrl + D]

Checking this option enables the data logging feature. If status bar is enabled, “Logging” and a file path will be displayed at bottom of screen. Un-checking will stop the data log and save it to the file path indicated in the Status bar. Upon stopping the data log, you will prompted to viewthe data log.

ECU - Flash Map [Ctrl + Shift + F]

When a pass-through connection is present, you can use this function to send a reflash command to your Accessport.

ECU - Change ECU [Ctrl + G]

This feature is only available in the Accesstuner Professional software and it allows you to switch between the different ECUs supported by this software suite.

Help Menu

Help - About

Shows Accesstuner version and build date of software.

Help - Help [F1]

Opens a Help File document containing information relating to Accesstuner.

Help - Updates

  • Check for updates - Checks the Accesstuner updates server for software updates.

  • Rollback last update - Rollback to the previous version of Accesstuner.

    • Note: Feature is not supported after a fresh install from an installer.
    • Note: Option is available immediately after updating Accesstuner through the "Check for updates" option.

Help - View Log File

This can be used to view error logs generated by the Accesstuner software and Accessport.

Help - Open Log Folder

Opens file folder in operating system where Accesstuner stores error log files.

Program Shortcuts

The Accesstuner software uses several standard Windows keyboard shortcuts for table editing, as well as others unique to the software. Most keyboard shortcuts can be found to the right of their corresponding action in the software's drop-down menus.
Table Manipulation Shortcuts:

  • Small Increase Value [ + ]
  • Large Increase Value [ Shift + ]
  • Small Decrease Value [ - ]
  • Large Decrease Value [ Shift - ]
  • Interpolate Horizontal [ H ]
  • Interpolate Vertical [ V ]
  • Multiply Value [ M ]
  • Direct Input Value [ E ] - Alternatively newer versions of Accesstuner allow you to enter a value directly into a table cell(s).